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NONROAD2005 Training
Craig Harvey, US EPA, OTAQ

15th Annual Emission Inventory Conference
New Orleans, Louisiana
15 May 2006
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Logistics
Hours: 1:30 PM - 5:00 PM

One break

Please turn off or set pagers and cell phones on 
vibrate

If you need to talk on your cell phone, please 
leave the room.
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Training Support
NONROAD Model Team:

Craig Harvey
Penny Carey
Larry Landman

And on nonroad NMIM issues: 
Harvey Michaels

Web
http://www.epa.gov/otaq/nonrdmdl.htm

Email
nonroad@epa.gov
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Course Objectives

Overview of NONROAD2005
versus NMIM and NR2004

Running NONROAD from the GUI
Creating output summaries with the 
reporting utility
Viewing and post-processing raw output
Modifying inputs
Using new features of NONROAD2005
Deciding whether to use NONROAD vs NMIM
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Other topics, as time permits:
Using Daily Temperature & RVP inputs

Getting & using “By-Model-Year” output

BATch (multiple) model runs

Site-specific inventories 

Growth and Technology Year inputs

Creating your own Access queries
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Topics You Care About? 
What modeling challenges do you face?

What is the most creative thing you’ve done (or 
tried to do) using NONROAD?

What would you love to be able to model that 
you can’t?

etc.
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Logisitics (cont.)
For the hands-on exercises, I’ll explain how to 
do it while I do it, then you do it, asking 
questions as needed.

So pay attention rather than typing along.
Work together – you’ll learn more.
If you finish an exercise, please help others who are 
having trouble.
Ask questions if you get stuck.
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Expected Preparation
NONROAD2005 software installed

Basic familiarity with the Windows operating system
Browsing folder structure with Windows Explorer

How to use Notepad or another text editor

How to open Excel or other spreadsheet
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Questions
Feel free to ask at any time -- if you are 
confused, so are other people
The answer may be

I’ll cover that later
I don’t know
I’ll provide an answer later by email
Out of the scope
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Miscellaneous

We won’t be able to cover everything

Apologies to the most experienced for going 
too slowly, and to novices for possibly going 
too quickly

Students are from States, EPA, RPOs, MPOs, 
cities, consulting firms, industry, etc.

I’ll be here only through Tuesday morning
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Course Materials

Handouts
These slides
NONROAD2005 Update Chronology

Documentation on install disk or download
NONROAD2005 User’s Guide
NONROAD Model Technical Reports 
( NR-001  – NR-015 )
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What is NONROAD2005
Final version of nonroad equipment 
inventory model

Generates inventory estimates for
All off-highway mobile equipment & recreational vehicles
Except locomotive, commercial marine, and aircraft

Several draft versions issued since 1998, last was 
2004
Changes since NONROAD2004 are in later slide
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NONROAD Model Overview

Stand Alone (No User Data Necessary)

Differentiated by Equipment Type and Other 
Characteristics
HC, CO, NOx, PM, SO2, CO2 

Equip Population & Fuel Consumption
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Past, Present, and Future Years
1970 - 2050 

Temporal Allocation
Annual, Seasonal, Monthly, Typical Day

Geographic Allocation
US, State, County

NONROAD Model Overview
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Graphical User Interface (“GUI”, Visual Basic)

Scenario definition

Core Model (Fortran)

Calculations
Generates raw output (.OUT file)

Reporting Utility (Microsoft Access)

Output summaries

NONROAD Model Overview
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How NONROAD Works

Reporting Utility

OUT file

Core ModelInput data files

Access Report Excel file

OPT fileGUI

Import to Excel
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Input Options
Evaluation Year
Temporal Period
(Year, Season, Month, Weekday, Weekend day)

Geographic Area (National, State, County)

Equipment Types (by fuel type, Hp, SCC)

Fuel Characteristics (RVP, sulfur, oxygen)
Temperature (min, max, avg)

NONROAD Model Overview
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Output Options
From Core Model

ASCII File (.OUT comma separated text)

From Reporting Utility (Access not required)

Pre-formatted MS Access Reports 

Access database tables (NIF 3)

Excel Spreadsheet

NONROAD Model Overview
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Pre-Formatted Inventory Reports
Tons by County
Tons by Source Category
Tons by Equipment type & SCC
Tons By Horsepower range

Emission Factor Reports
Grams per Day by SCC (& Hp)
Grams per Operating Hour by SCC (& Hp)
Grams per Hp-Hour by SCC (& Hp), exhaust only

NONROAD Model Overview
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Exhaust Emissions Calculation 

PopRPLFActDFEFI ⋅⋅⋅⋅⋅=
I = Exhaust Emissions Inventory (ton/year)
EF = Emission Factor (g/hp-hr)
DF = Deterioration Factor 
Act = Activity (hours/year)
LF = Load Factor
RP = average rated power (hp)
Pop = Equipment population (units)

NONROAD Model Overview
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NONROAD versus NMIM

What NMIM does that NONROAD does not:
Multiple county-specific temperature & fuel 
properties in a single run
Full fleet-specific retrofit modeling
Ammonia (NH3) and Toxics (HAPS)
Distributed processing (multiple computers)
National county-level inventories for the National 
Emission Inventory (NEI) and AQ modeling



23

NONROAD versus NMIM

What NONROAD does that NMIM does not:
Equipment population & fuel consumption output*
Detailed output by specific evap pollutant*
Seasonal, annual, or typical day outputs
(but you can post-process to get most of these)
Inventory years prior to 1999
Daily temperature inputs. 

* (unless run NMIM from DOS and ask for OUT file)
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NONROAD2005
Changes from NONROAD2004

Added evap categories: tank permeation, hose permeation, 
running loss, and hot soak
Enhanced output:  Load Factor & Avg Hp
Revised diurnal methodology and estimates
Includes Rec/Large SI rule evap controls
Updated scrappage/age distribution
Updated state and county allocations
Daily inputs for temp and RVP at national/state level
Adds Puerto Rico and the Virgin Islands
Added report options (especially Emission Factors)
Added diesel retrofit modeling capability
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NONROAD2005 vs NR2004
SI THC total (exh & evap)
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NONROAD2005 vs NR2004
SI NOx
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Future Changes
Update per future rulemakings 
( e.g., likely small gasoline engines and 
recreational marine, final rule in 2007? )
Transition to MOVES ( draft in 2007/2008? )
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Questions?

... on what NONROAD2005 is, or changes since 
NONROAD2004 ?
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Hands-on Exercises
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Configuring NONROAD
Relevant files &  directory structure:

nr-gui.ini
template.opt (note use of relative file paths)

c:\nonroad
\data

\activity
\allocate
\daily
\detfac
\emsfac
\retrofit
\season
\tech

\outputs
\reports
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Exercise 1:  Use GUI to Run 
NONROAD with default data

Open GUI (nrgui.exe)
Save as... nrtest1.opt  (suggest in outputs folder)
Scenario => Options, Period, Region, Sources 
(make any desired changes)
Model => Run with nrtest1.opt
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Post-run checks
If DOS window is still open, look at it for errors 
and warnings. 
Open MSG file to check for errors and warnings
Can open OUT file in text editor to check for 
desired counties, SCCs, pollutants
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Exercise 2:  Use Reporting 
Utility to Generate Reports
From GUI select Model => Reports
In Reporting Utility select

Data => Re-attach tables (only needed after 
install)
Data => Import data
Give brief description such as location, year, & 
scenario designation (e.g., “Base”)

Select Reports => Emission Totals by SCC
Select Run, Pollutants, Fuel, HC & PM types
Run
File => Export to Excel
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Exercise 3:  Postprocessing with 
Excel

Open Excel (or other spreadsheet software)
Select File => Open...

c:\nonroad\outputs\nrtest1.out
Delimited:  comma (only)

Scroll to bottom and add a Totals line
= sum( )  select lastcell up to firstcell.
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Exercise 4: Export to NIF3

In Reporting Utility...
Select Data => Export NIF File
Choose available simulation to export
Fill in contact info and any notes
(See sample on next slide)
Click Export button
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Exercise 4: Export to NIF3
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Save as niftest1.mdb (Access MDB file)
Click Open button, which saves the file
Double-click on niftest1.mdb, which should 
open MS-Access
Look at database tables

Exercise 4: Export to NIF3
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Inputs you might modify
Equipment population (*.pop)
Activity (activity.dat)
Geographic allocation (*.alo)
Temporal allocation (season.dat)
Growth at state level (*.grw)

We recommend not changing
Emission Factors (*.emf)
Deterioration Factors (*.det)
Useful life and scrappage (*.pop)

Exercise 5: Modify Input Data
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Working with ASCII data files
Use Text Editor (e.g., Notepad) not word processor
Must be in proper space-delimited vertical columns
If display font option, use Courier or Courier New
No word wrap
Use spaces not tabs
Refer to column descriptions near top of each file
Actual data is inside “packets”
/POPULATION/
... data ...
/END/
Anything outside of packet is just a comment

Exercise 5: Modify Input Data
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Exercise 5: Modify Input Data
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Saving from Excel spreadsheet
Save As... Formatted Text (Space delimited)(*.prn)
Column widths & font sizes must be set to yield text 
in correct columns
Setting this up can be tedious trial & error
Can request sample XLS files from EPA
No guarantee that settings will work right on 
different systems, due to effects of: 

Desktop display settings
Fonts
Print driver
etc.

Exercise 5: Modify Input Data
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Exercise 6: Running from DOS

Why run from the Command line? 
(DOS window)

Run BATch file (multiple model runs)
Can send screen output to a file
c:\nonroad>nonroad.exe template.opt >outputs\screenout.txt

Verify that core model works if having 
problems running from GUI
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Exercise 6: Running from DOS
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Exercise 6: Running from DOS

Example BATch file
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Ongoing Support

Web
http://www.epa.gov/otaq/nonrdmdl.htm

Email
nonroad@epa.gov
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NONROAD2005 Update Chronology 
 
 
 
Reporting Utility Updates: (reports.mdb) 
 
Dec 21, 2005, version 2005a 
 - Fix Leap Year operation (just treat it like other years). 
 - Change Pop/Fuel decimal places from 2 to 0, 1, or 2, depending on aggregation level. 
 
Jan 31, 2006, version 2005b 
 - Remove limit on number of Import Data records. 
 
Mar 21, 2006, version 2005c 
 
 - Fixes the reporting utility Export to Excel function for emission factor reports.  
 - Corrects the NIF export label for hydrocarbons from "HC" to "VOC" (since the 

NONROAD2005 reporting utility has always exported VOC when exporting to NIF).  
 - Adds CNG fuel volume explanation to Fuel Consumption reports. 
 - Adds reporting utility version number to all report page footers. 
 
 Please see the file rpt05c-mdb.txt in the nonroad\Reports\ folder for a more complete 

description of all these changes and other issues to be aware of when using the 
reporting utility.  

 
 
Core Model Updates: (nonroad.exe) 
 
Feb 8, 2006  
 
 A problem was corrected in the core model (NONROAD.EXE file only) with the 

calculation of evaporative Diurnal, Tank Permeation, and Hose Permeation emissions 
for time periods less than annual (i.e., seasonal, monthly, or typical day). Annual 
model runs did not have the problem. Outputs generated from this corrected version 
of the core model will say: 

 
  "Core Model Ver 2005a, Feb 2006"  
instead of:  
  "Core Model Ver 2005, Nov 2005" 
 
 
Data File Updates: 
 
Jan 13, 2006 
- Corrected geographic allocation files for Puerto Rico and Virgin Islands 

(PR_WIB.ALO, VI_WIB.ALO, VI_RVPRK.ALO). 



 2

 
Jan 26, 2006 
 - Corrected geographic allocation file for Washington D.C. recreational vehicle parks 

(DC_RVPRK.ALO).  
 
Feb 1, 2006, corrected geographic allocation file for West Virginia underground mining 

equipment (WV_COAL.ALO).  
 
 
=============================================================== 
 
 
Keeping Yourself Informed 
 
Web:    http://www.epa.gov/otaq/nonrdmdl.htm 
 
Listserver:  send blank email to:  join-EPA-MOBILENEWS@lists.epa.gov 
 
Email:  nonroad@epa.gov 
 
Fax:   734-214-4939 
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