10.14 View Time Series Output

10.14 View Time Series Output
Click this button to display output from the model run in either a text or graphical format.
The “View Time Series Output” window (Screen 10.14.1) provides options to view data for Pervious land
units, Impervious land units, Reaches, or Weather Station data. Click the radio button beside the name of the
module for which you wish to view data. You will be able to view only data for the parameters and
corresponding land units or reaches you chose in the “Output Manager” window prior to executing the model
or, in the case of weather stations, only data for the stations you chose to print output for in the “Simulation
Time and Meteorological Data” window.
For example, if you selected to view only daily mean surface outflow for agricultural pervious land in all of the
watersheds being simulated, you would be able to view only “Agricultural Land” in the “Pervious” list.

Screen 10.14.1

Viewing Output in a Text Format
1. View output in a text format by highlighting the appropriate Pervious or Impervious land unit, Reach,
or Weather Station from the Pervious, Impervious, Reach, and Weather Station lists and clicking the
Report button in the “View” box. The output file for the selected land unit, reach, or weather station is
automatically displayed in the WordPad text editor. The file name is listed in the top left corner of the
WordPad window. A sample output file is shown in Screen 10.14.2. The text file viewer can be
changed by selecting Select Output File Viewer... from the Project menu heading in the NPSM
interface.
10.14-1

BASINS Version 2.0

Screen 10.14.2

A brief description of important information in the output file (by line number) follows:
•

Line 2 lists the selected print time interval and the end month of the simulation period.

•

Line 3 lists the number of point- and mean-valued and total time series in the output file.

•

Line 5 lists the plot title.

•

Lines 12 to 21 list the parameters for which time series data are displayed in the output file.
The order of these parameters corresponds to the order of the columnar data beginning at Line
27 and Column 6. These columnar data, beginning at Line 27 and going to the end of the file,
are the time series output for the selected period, printed at the selected time interval. Column 1
is the year, Column 2 is the month, and Column 3 is the day. Column 6 is the data for the
parameter listed in Line 12. Columns 7 to 15 (if output) contain the data for the parameters
listed in Lines 13 to 21, respectively.

2. To stop viewing the output file, either click the X in the top right corner of the window or select
Exit from the File menu heading. This returns you to the “View Time Series Output” window.
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TUTORIAL
•

Click the Reaches radio button.

•

Highlight Blacklick Cr.

•

Select Report to view the text version of the model output for Backlick Cr.

•

Exit the text window by clicking the X in the top right corner.

Viewing Output Graphically in the NPSM Postprocessor
You can view output in a graphical format for a Pervious land unit, an Impervious land unit, or a Reach by
highlighting the appropriate land unit or reach and clicking the Graph button from the “View” box (Screen
10.14.1). This executes the NPSM postprocessor. The postprocessor supports daily, monthly, and annual
NPSM output. Weather Station data from NPSM is in an hourly format and therefore cannot be viewed in the
postprocessor.
The NPSM postprocessor displays NPSM simulation output, BASINS water quality observation data, and
USGS flow data in a graphical format. It also performs basic statistical functions and data comparison.
Because of its ability to display observed and modeled data concurrently and perform basic statistical and data
comparison functions, the postprocessor is a useful tool in model calibration and environmental systems
analysis. The postprocessor window (Screen 10.14.3) consists of a tool bar, a plot area, a file information
section, and a statistical functions section.

Screen 10.14.3
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Tip:

To exit the NPSM Postprocessor and return to the “View Time Series Output” window at any
time, simply click the X button at the top right corner of the postprocessor window or select Exit
from the File menu heading. Additional output data can be viewed in the same manner. To exit
the viewing section, click the Done button.

Loading and Viewing Data
The NPSM postprocessor has the ability to display three different data types—NPSM output files, BASINS
water quality observation data, and USGS flow data.
When the NPSM postprocessor is executed through selection of a Pervious land unit, Impervious land unit, or a
Reach from the “View Time Series Output” window, data are loaded automatically into the postprocessor.
Although data are loaded, they cannot be viewed until a parameter is selected from the “Plot(s) Selection”
window (Screen 10.14.4). Select a parameter from the pull-down menu. Click the right or left arrow to
designate which axis will display the data scale. Click OK when finished. Data are then displayed in the plot
area.
Additional data can be loaded into the postprocessor and viewed by using the tool bar buttons or by selecting

Screen 10.14.4

the appropriate file type from the File menu heading. All data loaded into the postprocessor must have the
same time interval—daily, monthly, or annual. Once data have been loaded, they cannot be viewed until the
Plots button is clicked and a parameter is selected from the “Plot(s) Selection” window.
1. Load additional NPSM output by clicking the NPSM Data button. You will be prompted to select a
file name. Recall that your NPSM output file is located in the directory that you designated in the
“NPSM Output Manager”, under the name automatically assigned to it. Generally, this location is the
BASINS\MODELOUT\<project name> directory.
2. Load BASINS water quality observation data by clicking on the BASINS Water Quality Data button.
You will be prompted to select a file. This is the file created when using the Export Water Quality
Observation Data utility in BASINS. You can specify the location of the file during execution of the
function; however, the default location is the BASINS\MODELOUT\OBS directory. The file will have
an .obs extension. Refer to Section 7.4, Water Quality Observation Data Management Utilities, for
directions on appending local water quality data to existing BASINS water quality observation data
and exporting BASINS water quality observation data.

10.14-4

10.14 View Time Series Output

3. Load USGS flow data by clicking the USGS Flow Data button. You will be prompted to select a file.
The BASINS USGS Gage Stations data layer contains mean flow, critical low flow (7Q10), and
monthly mean flow data for some USGS gage stations. For a typical model calibration, however, it is
suggested that you download daily flow data from the USGS’s United States NWIS-W Data Retrieval
web site. The URL is http://h2o-nwisw.er.usgs.gov/nwis-w/US/. From this web page, select the state
of interest. On the subsequent page, either enter the USGS station number of interest and “Retrieve
Data” or view a map, a list of counties, a list of basins, or a list of all stations to find the station of
interest. After selecting the station of interest, observe the Data Types Available. For a typical model
calibration, select the “Historical Streamflow Daily Values”. Historical streamflow daily values are
available for many but not all USGS stations. After selecting “Historical Streamflow Daily Values”,
enter the appropriate Dates to Retrieve and select the Output format as a “Tab-delimited text data file”
with the “MM/DD/YYYY” date format. Retrieve these data and save them to your hard drive.
Postprocessor Components
1. The files and parameter names are listed in the file information window in the bottom right portion of
the screen.
To display a parameter or multiple parameters from a loaded file, click the “Plots” button located
under the file information window. Select a file and parameter(s) from the pull-down menus on the
“Plot(s) Selection” window (Screen 10.14.4). Once a parameter is selected, click the right or left arrow
to designate which axis will display the data scale. Click OK when finished.
The file information window lists the File Name, Color (as it’s displayed in the plot area), Description,
and six additional columns of information referring to statistical output (which will be discussed with
the statistical functions). The scroll bar directly below the window lets you view all columns in the
table. Loaded data can be removed from the postprocessor by highlighting the appropriate file name,
clicking the right mouse button, and selecting Delete.
2. The “File Information” box above the window displays the range of dates for data loaded into the
postprocessor. For NPSM output files, this period matches the simulation period assigned in the
“Simulation Time and Meteorological Data” window. The BASINS water quality observation data
period depends on the availability of data for the monitoring station(s) selected when executing the
Export Water Quality Observation Data utility in BASINS. The period of record for the USGS flow
data is specified when downloading the data from the USGS web site.
3. Clicking the “Plot Manager” button opens a plot manager or “Layer Control Data” window (Screen
10.14.5). This window is used to change the color, line type, and thickness of plots and/or to remove
data previously loaded into the postprocessor.
To remove data from the postprocessor, highlight the file name and click the Remove button. To
remove all plots, click the Remove All button.
To change a plot color, highlight the file name and double-click on the colored box next to “Color:”.
Select a new color from the “Color” window and click OK. Then click the Update button to save this
change. Note that the colored box located next to the file name changes color.
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To change a plot line type, highlight the file name and change the line type in the “Symbol” box. Click
the Update button to save this change.
To change a plot or line thickness, highlight the file name and change the integer value in the “Line”
box. Click the Update button to save this change. Note that the line number in the file table is updated.
After making all necessary changes in this window, click the Close button.

Screen 10.14.5

4. The plot area consists of the plot window, x- and y- axis labels and boundary designation boxes, and a
“point display” section.
The plot period initially displayed represents the entire extent of data loaded into the postprocessor.
The time period represented on the plot can be changed by varying the Start and End dates using the
boxes located under the x-axis. The plot period boxes represent month, day, and year (from left to right)
for both the Start and End dates. Values in these boxes can be changed by clicking the cursor within a
box and changing its value or by clicking on the up and down arrows next to each box. Depending on
the time interval of the data loaded into the postprocessor, some of these boxes may not be active.
The minimum and maximum value of the y-axis can also be changed in a similar manner.
After making any changes to values in the plot period boxes, click the Refresh button located on the tool
bar.
The “point display” section of the graph is the area located between the two bold lines, containing the
words “Selected” and “Corresponding value(s)”. This region is used to display point values for the plot.
Click the cursor at any location in the plot window. The date corresponding to the point where the
cursor is clicked is displayed in addition to the associated parameter value. The parameter value is
displayed in the same color as its plot. If multiple output files containing time series data for the same
parameters have been loaded into the postprocessor, multiple parameter values appear in the “point
display” section.
5. Statistical operations are executed from the “Statistical Calculation:” section of the postprocessor. The
postprocessor calculates and plots either the running arithmetic or geometric mean for the parameters
listed in the “File Information” section of the postprocessor (Screen 10.14.6). Statistical output
10.14-6

10.14 View Time Series Output

summaries are created and listed in the “File Information” section of the postprocessor. The statistical
operation is performed for the time period shown in the plot window.
The statistical calculation can be modified by selecting either “Arithmetic Mean” or “Geometric Mean”
from the “Statistical Method:” box and designating “Step” and “Threshold” values. The “Step” value
refers to the incremental number of output file time steps over which the value is statistically averaged.
For example, a step length of 30 for daily data would be used to plot the 30-day geometric mean.
The “Threshold” value is the value against which the parameter values are compared (typically a
pollutant standard). The threshold value is displayed as a line on the statistical plot (y = threshold), and
the statistical output summaries are based on this value. The “Step” and “Threshold” values are edited
by entering a value directly into the appropriate boxes. Click on the Refresh button to plot the
threshold value and recalculate the exceedance statistics.

Tip:

To view a plot of the original data (not the statistical plot), set the “Step” to 1 and the “Threshold”
to 0.

The statistical output summaries are presented in the “File Information” section for each file. The
summaries contain the following information:
•

No. of Exceedances—the total number of periods in which the running mean (either arithmetic or
geometric) is above the threshold value. A single exceedance may consist of a single day or
multiple consecutive days.

•

Maximum No. of Days—the total number of days in the longest single exceedance, or the period
over which the threshold is exceeded for the most consecutive days.

•

Minimum No. of Days—the total number of days in the shortest single exceedance, or the period
over which the threshold is exceeded for the least consecutive days.

•

Total No. of Days—the total number of days during which the threshold value is exceeded.

•

Exceedance Percentage—the total number of days during which the threshold value is exceeded,
divided by the total number of days in the period of time represented on the statistical plot.

Negative and zero values in any data sets loaded are ignored during statistical calculations.

Tip:

The statistical output summary table can be saved to a file by selecting the Save Report option
from the File menu heading.
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Screen 10.14.6

6. The postprocessor can also provide a basic comparison of data. This function is best applied to time
series loading data from multiple simulation runs. It is executed by clicking the Data Comparison
button.
The “Data Comparison” window (Screen 10.14.7) prompts you to select two files—one in the
“Simulation 1" box and another in the “Simulation 2" box. To compare different loading scenarios, the
selected files should be from different simulation runs and should represent the same land unit, reach, or
watershed. The resulting output displays:
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•

The Simulation 1 loading value—the total loading integrated over the period plotted for the selected
parameter in the “Simulation 1" file.

•

The Simulation 2 loading value—the total loading integrated over the period plotted for the selected
parameter in the “Simulation 2" file.

•

The Difference—the difference between the Simulation 1 and Simulation 2 loading values
(Simulation 1 - Simulation 2).

•

The % Increase or % Reduction—if the “Difference” value is negative, the corresponding %
Increase value is displayed. If the “Difference” value is positive, the corresponding % Reduction is
displayed.
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Click Close to close the window. The loading values, or areas under each curve, are also listed in the
file information window in the “Area Under the Curve” column.

Screen 10.14.7

Printing Plots
The NPSM postprocessor can also print the plots displayed in the plot window. From the File menu heading,
select Print Preview to view the page layout (Screen 10.14.8). From this window, you can print, view multiple
pages, and zoom in or zoom out. To add a title to a plot, click Close to return to the NPSM postprocessor
window, click on the Edit menu heading, and select Title.
The plot can also be printed by selecting Print from the File menu heading. Be sure that the proper printer
settings have been made (select Print Settings from the File menu heading).
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Screen Screen 10.14.8

TUTORIAL
•
•
•

•
•
•

•
•

In the “View Time Series Output” window, click the Reaches radio button.
Highlight Blacklick Cr.
Select Graph to execute the NPSM postprocessor. The data file you have loaded is the
BASINS\MODELOUT\TUTORIAL\REACHESR0_BLACK.012 file. From the “Plot(s)
Selection” window, select this file and the parameter DQAL (Fecal Coli.), by highlighting it
in the parameter box and clicking the << button. Click OK. The file name and parameter
will appear in the file information box.
Change the x-axis time period to represent 1/1/1982 - 12/31/1982.
Click on the plot area to view the fecal coliform concentration on any given day.
Change the “Statistical Method” to Geometric Mean, the Step Length to 30, and the
Threshold to 200. Click Refresh. Change the y-axis Max. to 400. The plot now displays a
line at the 200 #/100 ml level and a plot of the 30-day geometric mean for fecal coliform for
the year 1982. In the file information box, note the statistical information.
In the Plot manager, remove the R0_Black.012 file. Click Remove. Click Close.
Use the NPSM Data button to load the P0_agric.000 file in the
BASINS\MODELOUT\TUTORIAL\ALLSHEDS directory. This file contains the total flow and
total fecal coliform contributions from agricultural land in all subwatersheds.
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TUTORIAL (cont)
•

Use the NPSM Data button to load the P0_fores.000 file in the
BASINS\MODELOUT\TUTORIAL\ALLSHEDS directory. This file contains the total flow and
total fecal coliform contributions from forest land in all subwatersheds.

•

Click the Plots button and select the parameter SOQUAL for these two files.

•

Change the x-axis time period to 1/1/1982 - 12/31/1982.

•

Although the Data Comparison button is typically used to compare one simulation run to
another, it can also be used to compare pollutant loadings from different land uses. Click
the Data Comparison button. In the Simulation 1 box, select P0_agric.000. In the
Simulation 2 box, select P0_fores.000. Note the total fecal coliform loadings from each
land use (in the Simulation 1 loading and Simulation 2 loading boxes), the difference
between the two loadings, and the reduction (which in this example represents the percent
difference between loadings from the two land uses).

•

Exit the NPSM postprocessor to return to the “View Time Series Output” Window.
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